- R1 create 3 loopback network then advertise into ospf area 0.
lo0: 1.1.0.1/24
lo1: 1.1.1.1/24
lo2: 1.1.2.1/24
- Advertise loopback0 network R4 into ospf area 2.
- verify R1:
- Because area 2 are discontigous Non-AREA .router in area 0 havent route loopback R4.
- Config virtual-link btw R2 and R4 are slove problem.
R2#
router ospf 1
area 1 virtual-link 4.4.4.4
R4#
router ospf 1
area 1 virtual-link 2.2.2.2
=> Neighbor btw R2 and R4 over virtual-link up.
- in R2, summary 3 network learn via R1 into area 1.
1.1.0.0/24
1.1.1.0/24
1.1.2.0/24
=> summary route: 1.1.0.0/22
R2#
router ospf 1
are 0 range 1.1.0.0 255.255.252.0
- verify R3:
=> we have problem, 3 network advertise by R1 are not summary.
WHY ???
Area 1 should be transit and carry a virtual link and area 0 prefixes should be summarized in the transit area. Per OSPF functionality, it is impossible to summarize prefixes entering a transit area, as this may result in routing loops. Therefore, summarization requirement and virtual link do not work together well.
This solution to this problem is using a tunnel in area 0 as opposed to a virtual-link. The tunnel will encapsulate transit packets and hide them from R3, therefore preventing any possible forwarding loops due to summarization
R2#
router ospf 1
no area 1 virtual-link 4.4.4.4
area 0 range 1.1.0.0 255.255.252.0
!
interface Tunnel0
ip address 192.168.24.2 255.255.255.0
ip ospf 1 area 0
tunnel source 10.1.23.2
tunnel destination 10.1.34.4
R4#
router ospf 1
no area 1 virtual-link 2.2.2.2
area 0 range 1.1.0.0 255.255.252.0 not-advertise
!
interface Tunnel0
ip address 192.168.24.4 255.255.255.0
ip ospf 1 area 0
tunnel source 10.1.34.4
tunnel destination 10.1.23.2
- Verify R3:
No comments:
Post a Comment