Tuesday, March 10, 2015

EIGRP Filter

=====================  EIGRP FILTER  ========================================


1. offset-list
- the offset-list feature in EIGRP is used to modify the metric on a per_route basis or a per-interface basis.
+ Only apply theo chieu " in "

+ Only increases delay value.
+ accesslist used "permit"
+ change value delay
+ Metric increase = K3 * offset * (K5 / (reliability + K4))
+ In Eigrp it’s used to add to the existing delay value                


#offset-list [ACL] {in|out} {offset} {interface}

router eigrp 1
offset-list 1 in 2147483647 s0/0
!
access-list 1 permit 1.1.1.0 0.0.0.255


=============================================================================
2. distribute-list
- Filters all routes matching the ACL or prefix-list

distribute-list {ACL | prefix} {in|out}

std acl:

router eigrp 1
distribute-list 1 in Serial0/0
!
access-list 1 permit 1.1.1.0 0.0.0.255
extended acl:

In R2 :

access-list 100 deny ip host 1.1.1.1 host 10.1.12.1
access-list 100 deny ip host 1.1.2.1 host 10.1.12.1
access-list 100 deny ip host 1.1.3.1 host 10.1.12.1
access-list 100 permit ip any any
!
router eigrp 100
distribute-list 100 in Serial0/0

line : access-list 100 deny ip host 1.1.1.1 host 10.1.12.1
+ prevent R2 learn 1.1.1.1 from R1 ( 10.1.12.1 )


- Filters all routes to/from a neighbor

distribute-list gateway {prefix-list} {in|out} {interface}

- Filters prefix from a specific source from entering the routing table

distribute-list prefix {prefix-routes} gateway {prefix-source} {in|out}

- Changes the distance for both internal and external EIGRP routes

distance eigrp {ad-internal} {ad-external}

- Using Route-maps
  
router eigrp 100
distribute-list route-map FILTER_ON_TAGS in
!
route-map FILTER_ON_TAGS deny 10
match tag 4  { match length , match interface .... }
!
route-map FILTER_ON_TAGS permit 20

=====================================================================
3. Using Admin distance:


distance {AD} {address} {wildcard} {acl#|aclname}

- any source
  • Filter route internal
Distance {AD} eigrp internal  external
  • Filter all
access-list 1 permit 1.1.1.0 0.0.0.255
!
router eigrp 100
distance 255 0.0.0.0 255.255.255.255 1

-specific per neighbor

access-list 1 permit 1.1.1.0 0.0.0.255
!
router eigrp 100
distance 255 10.1.12.1 0.0.0.0 1
=======================================================================
4. Using redistribution with route-maps

router eigrp 100
redistribute rip metric 100000 100 255 1 1500 route-map RIP_TO_EIGRP
!
ip prefix-list VLAN_43 seq 5 permit 204.12.1.0/24
!
route-map RIP_TO_EIGRP permit 10
match ip address prefix-list VLAN_43
set tag 4
!
route-map RIP_TO_EIGRP permit 20

==================================================================

No comments:

Post a Comment