root@test# show
## Last changed:
2015-03-14 16:34:05 UTC
version 8.5R1.14;
interfaces {
em0 {
unit 0 {
family inet {
address 10.1.13.3/24;
}
family iso;
}
}
lo0 {
unit 0 {
family inet {
address 3.3.3.3/24;
}
family iso {
address
49.0001.0000.0000.3333.00;
}
}
}
}
protocols {
isis {
interface em0.0;
interface lo0.0;
}
}
|
R1#show run
interface
Loopback0
ip address 1.1.1.1 255.255.255.0
ip router isis 1
!
interface
FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
ip router isis 1
duplex auto
speed auto
!
interface
FastEthernet0/1
ip address 10.1.13.1 255.255.255.0
ip router isis 1
duplex auto
speed auto
!
router isis 1
net 49.0001.0000.0000.1111.00
|
RP/0/0/CPU0:ios#show run router isis
Sat Mar 14
23:39:11.758 UTC
router isis 1
net 49.0001.0000.0000.2222.00
interface Loopback0
address-family ipv4 unicast
!
!
interface GigabitEthernet0/0/0/2
address-family ipv4 unicast
!
!
!
|
Let's verify:
-----------------------------------------------------------------------------------------
root@test# run show isis adjacency
Interface System L State Hold (secs) SNPA
em0.0 R1 2
Up 8 c2:0:11:64:0:1
em0.0 R1 1
Up 9 c2:0:11:64:0:1
root@test# run show route protocol isis
inet.0: 7
destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, -
= Last Active, * = Both
1.1.1.0/24 *[IS-IS/15] 00:04:20, metric 20
> to 10.1.13.1 via em0.0
2.2.2.0/24 *[IS-IS/15] 00:04:19, metric 30
> to 10.1.13.1 via em0.0
10.1.12.0/24 *[IS-IS/15] 00:04:20, metric 20
> to 10.1.13.1 via em0.0
__juniper_private2__.inet.0:
1 destinations, 1 routes (0 active, 0 holddown, 1 hidden)
iso.0: 1
destinations, 1 routes (1 active, 0 holddown, 0 hidden)
[edit]
root@test# run show isis database
IS-IS level 1 link-state database:
LSP ID Sequence Checksum Lifetime Attributes
R1.00-00 0x6 0x6b3a 615 L1 L2
R1.01-00 0x2 0x8a42 790 L1 L2
R1.03-00 0x1 0xc2e6 611 L1 L2
0000.0000.2222.00-00 0x5 0x6f1 802 L1 L2
test.00-00 0x2 0xab5 611 L1 L2
5 LSPs
IS-IS level 2 link-state database:
LSP ID Sequence Checksum Lifetime Attributes
R1.00-00 0x9 0x4571 619 L1 L2
R1.01-00 0x2 0x1a3b 787 L1 L2
R1.03-00 0x1 0x52df 611 L1 L2
0000.0000.2222.00-00 0x8 0x63da 613 L1 L2
test.00-00 0x4 0x3daa 618 L1 L2
5 LSPs
[edit]
-----------------------------------------------------------------------------------------
R1#show isis ne
Area 1:
System Id Type Interface IP Address State Holdtime Circuit Id
0000.0000.2222
L1 Fa0/0 10.1.12.2 UP
28 R1.01
0000.0000.2222
L2 Fa0/0 10.1.12.2 UP
26 R1.01
test L1 Fa0/1
10.1.13.3 UP 25
R1.03
test L2 Fa0/1
10.1.13.3 UP 21
R1.03
R1#show ip route isis
2.0.0.0/24 is subnetted, 1 subnets
i L1 2.2.2.0 [115/20] via 10.1.12.2,
FastEthernet0/0
3.0.0.0/8 is variably subnetted, 2
subnets, 2 masks
i L1 3.3.3.3/32 [115/10] via 10.1.13.3,
FastEthernet0/1
i L1 3.3.3.0/24 [115/10] via 10.1.13.3,
FastEthernet0/1
R1#show isis da
Area 1:
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 * 0x00000006 0x6B3A 585 0/0/0
R1.01-00 * 0x00000002 0x8A42 762 0/0/0
R1.03-00 * 0x00000001 0xC2E6 581 0/0/0
0000.0000.2222.00-00 0x00000005 0x06F1 774 0/0/0
test.00-00 0x00000002 0x0AB5 577 0/0/0
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 * 0x00000009 0x4571 589 0/0/0
R1.01-00 * 0x00000002 0x1A3B 759 0/0/0
R1.03-00 * 0x00000001 0x52DF 581 0/0/0
0000.0000.2222.00-00 0x00000008 0x63DA 583 0/0/0
test.00-00 0x00000004 0x3DAA 584 0/0/0
Area null:
Area [1:
-----------------------------------------------------------------------------------------
RP/0/0/CPU0:ios#show isis adjacency
Sat Mar 14
23:43:14.751 UTC
IS-IS 1 Level-1
adjacencies:
System Id Interface SNPA State Hold Changed NSF IPv4 IPv6
BFD BFD
R1 Gi0/0/0/2 c200.1164.0000 Up 8
00:18:10 Yes None None
Total adjacency
count: 1
IS-IS 1 Level-2
adjacencies:
System Id Interface SNPA State Hold Changed NSF IPv4 IPv6
BFD BFD
R1 Gi0/0/0/2 c200.1164.0000 Up 8
00:18:10 Yes None None
Total adjacency
count: 1
RP/0/0/CPU0:ios#show ip route isis
Sat Mar 14
23:41:19.649 UTC
i L1 1.1.1.0/24
[115/20] via 10.1.12.1, 00:15:58, GigabitEthernet0/0/0/2
i L1 3.3.3.0/24
[115/20] via 10.1.12.1, 00:04:54, GigabitEthernet0/0/0/2
i L1 3.3.3.3/32
[115/20] via 10.1.12.1, 00:04:54, GigabitEthernet0/0/0/2
i L1 10.1.13.0/24
[115/20] via 10.1.12.1, 00:04:59, GigabitEthernet0/0/0/2
RP/0/0/CPU0:ios#show isis da
Sat Mar 14 23:47:05.595 UTC
IS-IS 1 (Level-1) Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 0x00000006 0x6b3a 558 0/0/0
R1.01-00 0x00000002 0x8a42 734 0/0/0
R1.03-00 0x00000001 0xc2e6 554 0/0/0
0000.0000.2222.00-00* 0x00000005 0x06f1 749 0/0/0
test.00-00 0x00000002 0x0ab5 550 0/0/0
Total Level-1 LSP count: 5 Local Level-1 LSP count: 1
IS-IS 1 (Level-2) Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 0x00000009 0x4571 562 0/0/0
R1.01-00 0x00000002 0x1a3b 731 0/0/0
R1.03-00 0x00000001 0x52df 554 0/0/0
0000.0000.2222.00-00* 0x00000008 0x63da 559 0/0/0
test.00-00 0x00000004 0x3daa 557 0/0/0
Total Level-2 LSP count: 5 Local Level-2 LSP count: 1
RP/0/0/CPU0:ios#
No comments:
Post a Comment